OPENVPN AUTOMODE/Service.

Nesta parte do fórum tratamos das novidades, informações e dúvidas acerca dos assuntos relacionados com a área escolar.
Bloqueado
Avatar do Utilizador
admin
Site Admin
Mensagens: 80
Registado: Segunda Nov 14, 2005 1:35 pm
Contacto:

OPENVPN AUTOMODE/Service.

Mensagem por admin » Segunda Out 24, 2011 12:05 am

Pode haver necessidade de colocar o OpenVPN a correr sob serviço se:

1 - Tivermos administradores e utilizadores nas máquinas Win2K/XP , pois os utilizadores não conseguem iniciar o interface OpenVPN no GUI - ele dará erro por causa das permissões - ligar o túnel implica que hajam alterações das interfaces de rede, o que de um ponto de vista do sistema operativo somente os administradores o podem fazer.

2 - Tivermos necessidade de o sistema ligar-se automaticamente ou estar permanentemente online sem intervenção humana.

PORTANTO PARA ISSO TEMOS QUE :

Mover os ficheiros de certificado ( se é que ainda estão ) no sub-directório criado pelo ZIP e colocar os mesmos ficheiros na raiz do directório config. O sistema só arranca automaticamente os certificados instalados dentro deste, ao contrário do OpenVPN-GUI que pode gerir vários dento de sub-directórios.

Ir ao painel-de-controlo e entrar nas "Ferramentas Administrativas".
Lá deverão executar o MMC "Serviços" - é representado por um icone de duas rodas-dentadas amarelas - no caso do Win2K/XP - nos outros não sei - não tenho !

Procurar o OpenVPN Service, e lá dentro trocar o TIPO DE ARRANQUE de Manual para Automático. Carregar no APLICAR e de seguida Carregar no INICIAR. Nesta altura se dá o arranque do serviço, e se tudo estiver OK, passados poucos segundos a interface OpenVPN Irá ligar-se - será mostrado o "balão" de notificação do Windows desse acontecimento.
Se isso não acontecer é porque os certificados foram mal colocados ou não há rede...

Ver Abaixo a ilustração.
Anexos
passosfinais_135.jpg

Bloqueado

Quem está ligado:

Utilizadores neste fórum: Nenhum utilizador registado e 1 visitante